Citrix Files latency and loading issues resolved, 06/12/2019 11:51AM EDT Content Collaboration Content Collaboration


Notification history

06/12/2019 11:51AM EDT
Resolved - At this point, we believe we have made the appropriate adjustments to deem this issue resolved. We will continue to monitor for any additional issues. 
Should further issues be seen, please contact Citrix Technical Support. 
Jun 12, 11:48 EDT
06/12/2019 11:19AM EDT
Investigating - We have been made aware of issues ongoing for certain users of the Citrix Files application and tools. Users may be experiencing latency and loading issues with the web application and tools. 

We are working to research and resolve the issue and will provide updates as soon as additional information is available. 
Jun 12, 11:19 EDT